『1149』Dangerous Goods Packaging

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers:  , the number of pairs of incompatible goods, and  , the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]

where K (≤1,000) is the number of goods and G[i]‘s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

Ω

今天真的是水逆,一会TLE,一会MLE,总之每次第一个思路总是错的,可恶。

给出 对不能一起运输的物品ID,随后输入 个运输清单,输出能否运输。就连这种题目都不能一边过,服了。

一开始我打算用一个set<long long>存储不能一起运输的物品ID,假设 是一对不能一起运输的物品,那么就将查询索引 存入set。在读入一个运输清单时,将每一个读入物品与之前读入物品组成查询索引在set中查找,如果找到了就说明不能一起运输。结果后面两个测试点TLE了。后来我想直接给每个物品开一个bitset<100000>来记录不能一起存储的物品,结果ME(Memory Limit Exceeded)。

最后采取常规做法,用map<int,vector<int>>建立ID到不能一起运输物品集的映射,然后每读入一个物品就将不能和其一起运输的物品ID进行标记,如果后面出现了标记过的物品,则说明这单不能运输。事实证明,中庸才是王道,我之前的两个做法分别在时间和空间上过于极端(当然题目限的太狠也是一个因素

反思了一下,最开始建立的那个查询索引会让索引量增长到 ,set和map内部的数据结构都是红黑树,查找效率在 ,那么 会让时间增长一倍,这确实是一笔不小的开销。


🐎

#include <iostream>
#include <vector>
#include <bitset>
#include <map>

using namespace std;

int main()
{
    int n, m, a, b;
    scanf("%d %d", &n, &m);
    map<int, vector<int>> incap;
    for (int i = 0; i < n; ++i)
    {
        scanf("%d %d", &a, &b);
        incap[a].push_back(b), incap[b].push_back(a);
    }
    for (int i = 0; i < m; ++i)
    {
        scanf("%d", &n);
        bitset<size_t(1e5)> tmp;
        bool ans = true;
        for (int j = 0; j < n; ++j)
        {
            scanf("%d", &a);
            if (!ans) continue;
            if (tmp[a]) ans = false;
            for (auto &k: incap[a]) tmp[k] = true;
        }
        printf(ans ? "Yes\n" : "No\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值