『1156」Sexy Primes

Sexy primes are pairs of primes of the form , so-named since “sex” is the Latin word for “six”. (Quoted from http://mathworld.wolfram.com/SexyPrimes.html)

Now given an integer, you are supposed to tell if it is a sexy prime.

Input Specification:

Each input file contains one test case. Each case gives a positive integer  .

Output Specification:

For each case, print in a line Yes if N is a sexy prime, then print in the next line the other sexy prime paired with N (if the answer is not unique, output the smaller number). Or if N is not a sexy prime, print No instead, then print in the next line the smallest sexy prime which is larger than N.

Sample Input 1:

47

Sample Output 1:

Yes
41

Sample Input 2:

21

Sample Output 2:

No
23

Ω

性感(sexy,与six发音相近)素数指 同为素数的素数 。现在给出一个数 ,判断是否为性感素数,如果是就输出另一个最小的素数伙伴,否则输出最小且 的性感素数。

直接从 开始判断是否为性感素数,不是就+1,最后找到的第一个性感素数如果和 相等就输出“Yes”和它的素数伙伴,否则输出“No”和最小的性感素数。


🐎

#include <iostream>
#include <cmath>

using namespace std;

bool isPrime(int n)
{
    if (n < 4) return n > 1;
    for (int i = 2; i <= sqrt(n); i += (i != 2) + 1)
        if (n % i == 0) return false;
    return true;
}

int main()
{
    int n, m, k;
    cin >> n, m = n - 1;
    while (!isPrime(++m) || (!isPrime(k = m - 6) && !isPrime(k = m + 6)));
    printf("%s\n%d", m == n ? "Yes" : "No", m == n ? k : m);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值