「1131」Subway Map

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

subwaymap.jpg

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 100), the number of subway lines. Then N lines follow, with the i-th (i=1,⋯,N) line describes the i-th subway line in the format:

M S[1] S[2] … S[M]

where M (≤ 100) is the number of stops, and S[i]’s (i=1,⋯,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order – that is, the train travels between S[i] and S[i+1] (i=1,⋯,M−1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called “transfer stations”), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (≤ 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

samplemap.jpg

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi’s are the line numbers and Si’s are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

Ω

勾八题目,死给你看哦。其实不是很难,但我一直陷在BFS,百思不得其解。

给出地铁站图中所有线路的站台编号,要求你输出给定起点和终点站台的路线。如需换乘则还需输出换乘站台。优先输出过站最少的路线,如果有多条路线则输出换乘数最少的路线。

一开始,我还尝试了Dijkstra,不禁超时而且只ac了两个测试点。于是乎,我改用BFS结果还是只ac了两个。如果PAT考试里遇到这题,我怕不是已经千疮百孔了。经过几百次抓狂之后,仔细分析了一波,我在BFS中用pre数组存储最优路线的前置节点,但事实上你不往后走是无法确定到某个节点的路线是最优的,因为你还不知道终点在哪个方向,所以你不知道在这个节点上是否需要换乘,不同路线到达这个站台的换乘次数就会不同。当然你可以找到所有起点到终点站台数最少的路线,然后再逐一计算换乘数,取最小者。

最后发现所有的方法都会回到DFS,只有DFS能直接计算出到终点站共换乘了多少次。设置一个全局最优pair对opt,如果到终点的路线比opt优则记录路线并更新opt,同时用pos表示这条路原本在几号线上,如果接下去将要dfs的站台线号与当前路线线号不同则给trans+1。o对,注意到每个站台可能属于多个线路,而邻站之间的路线则属于唯一线路,因此用map<pair<int,int>,int>表示相邻站台之间的路线属于哪一线路。


🐎

#include <iostream>
#include <vector>
#include <map>

using namespace std;
map<pair<int, int>, int> line;
vector<vector<int>> edge(10000);
vector<bool> flag(10000, false);
vector<int> path, ans;
pair<int, int> opt{INT32_MAX, INT32_MAX};

void dfs(int s, int e, int trans, int pos)
{
    static int depth = 0;
    flag[s] = true, path.push_back(s);
    if (s == e)
    {
        if (make_pair(depth, trans) < opt)
        {
            opt = make_pair(depth, trans);
            ans = path;
        }
    }
    else
    {
        for (auto &k: edge[s])
        {
            if (flag[k]) continue;
            depth += 1;
            dfs(k, e, trans + (pos != line[{k, s}] && depth > 1), line[{k, s}]);
            depth -= 1;
        }
    }
    flag[s] = false, path.pop_back();
}

int main()
{
    int n, m, k, a, b, p;
    scanf("%d", &n);
    edge.resize(10000);
    for (int i = 0; i < n; ++i)
    {
        scanf("%d %d", &m, &p);
        for (int j = 1; j < m; ++j)
        {
            scanf("%d", &k);
            line[make_pair(k, p)] = line[make_pair(p, k)] = i + 1;
            edge[k].push_back(p), edge[p].push_back(k);
            p = k;
        }
    }
    scanf("%d", &m);
    for (int i = 0; i < m; ++i)
    {
        scanf("%d %d", &a, &b);
        dfs(a, b, 0, 0);
        printf("%d\n", opt.first);
        int l = line[{ans[0], ans[1]}], p = a;
        for (int j = 1; j < ans.size(); ++j)
        {
            if (line[{ans[j - 1], ans[j]}] != l)
            {
                printf("Take Line#%d from %04d to %04d.\n", l, p, ans[j - 1]);
                l = line[{ans[j - 1], ans[j]}], p = ans[j - 1];
            }
        }
        printf("Take Line#%d from %04d to %04d.\n", l, p, ans.back());
        path.clear(), ans.clear();
        opt = {INT32_MAX, INT32_MAX};
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值