B-Sum Problem
题干:
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
该题注意要输出的格式!!!!每组数据输出后要换两次行。
在计算从1开始的累加和时可以使用公式法,可以节约运行时间!!!
在vj中无特殊说明都是以文件结束
代码如下:
#include<iostream>
#define _ ios_base::sync_with_stdio(0),cin.tie(0)//加快读入数据
using namespace std;
int main()
{
int n;
while(cin>>n)
{
cout<<(1+n)*n/2<<endl<<endl;
}
return 0;
}