K - A+B for Input-Output Practice (VIII)

K - A+B for Input-Output Practice (VIII)

题干:

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6

注意点在输出格式上!!!!

相邻的两个输出直接有空行,意思是最后一行只需输出,不需要再加换行!

代码如下:

#include<iostream>
#define _ ios_base::sync_with_stdio(0),cin.tie(0)
using namespace std;
int main()
{
	int a;
	int n,m,sum;
	cin>>n;
	while(n--)
	{
		cin>>m;
		sum=0;
		while(m--)
		{
		     cin>>a;
			 sum+=a;	
		}
		cout<<sum;
		if(n!=0)
		{
			cout<<endl<<endl;
		}
		else
		{
			cout<<endl;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值