【PAT(甲级)】1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP​ programmers. Then every NG​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP​ and NG​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP​ distinct non-negative numbers Wi​ (i=0,⋯,NP​−1) where each Wi​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP​−1 (assume that the programmers are numbered from 0 to NP​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

解题思路:

题目给出Np只老鼠的体重,每个小组最多可以包含Ng只老鼠,如果剩下来的老鼠不足Ng只则把这些老鼠归为另一组。题目中的分组就是:

第一组:19  25  57           第二组:22  10  3           第三组:56  18  37           第四组:0 46

第一组:57  22  56           第二组:46

第一组:57  46

第一组:57

排名的顺序则是1-Np,如果有两个第三名,那么就没有第四名,而且第一次淘汰人的排名就算组数+1。所以排名的算法就是[(当前的所有人数/最大组内人数)的向上取整+1]。

代码:

#include<bits/stdc++.h>
using namespace std;

int main(){
	int Np,Ng;
	cin>>Np>>Ng;
	int Mice[Np];
	int rank[Np] = {0};
	queue<int> r,tr;
	for(int i=0;i<Np;i++){
		cin>>Mice[i];
	}
	
	for(int i=0;i<Np;i++){
		int t;
		cin>>t;
		r.push(t);
	}
	
	int group;
	if(Np%Ng==1) group = Np/Ng;
	else group = Np/Ng+1;
	
	while(group>=0){
        int rankl=int(ceil(r.size()*1.0/Ng));
		while(!r.empty()){
			int max = -1;
			int tip = -1;
			for(int i=0;i<Ng;i++){
				if(!r.empty()){//防止有的小组老鼠数量不足 
					int b = r.front();
					rank[b] = rankl+1; 
					r.pop();
					if(Mice[b]>max){
						max = Mice[b];
						tip = b;
					}
				}
			}
			tr.push(tip);
		}
        if(tr.size()==1){
            rank[tr.front()] = 1;
        }
        r = tr;
        queue<int> empty;
        tr = empty;//清空队列 
        group--;
	}
	
	for(int i=0;i<Np;i++){
		cout<<rank[i];
		if(i!=Np-1) cout<<" ";
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值