【PAT(甲级)】1069 The Black Hole of Numbers(易错点)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

解题思路:

就是字符串和数字之间来回转换,直到相减为6174为止,思路还是很简单的,需要注意的是这些数字永远都是4位的。

易错点:

测试点2,3,4都是因为忽略了数字永远都是4位的,降序排序的数字应该后补0,升序排序的数字应该前补0,直到数字为4位。

代码:

#include<bits/stdc++.h>
using namespace std;

map<int,int> turn_int(string a){
	map<int,int> r;int f=0,s=0;
	sort(a.begin(),a.end());
	for(int i = 0;i<a.size();i++){
		f=f*10+a[i]-'0';
		s=s*10+a[a.size()-1-i]-'0';
	}
    int times = a.size();
    while(times<4){// 当输入的字符串小于4位的时候,降序排序的那个数字需要后补0
        s*=10;
        times++;
    }
	r[f] = s;
	return r;
}

int main(){
	string N;
	cin>>N;
	int flag = 0;
	map<int,int> number;
	number = turn_int(N);
	auto i = number.begin();
	
	while(i->second - i->first != 6174){
		if(i->first == i->second) {
			printf("%04d - %04d = 0000\n",i->second,i->first);
			flag = 1;
			break;
		}
		printf("%04d - %04d = %04d\n",i->second,i->first,i->second-i->first);
		number = turn_int(to_string(i->second-i->first));
		i = number.begin();
	}
	if(flag == 0) printf("%04d - %04d = %04d\n",i->second,i->first,i->second-i->first);;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值