1007 Maximum Subsequence Sum PAT甲级真题 {小问题还需解决}

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

参考翻译:

给定K个整数序列{N1, N2,…, nk}。连续子序列定义为{Ni, Ni+1,…, Nj}其中1≤i≤j≤K。最大子序列是具有最大元素和的连续子序列。例如,给定序列{-2,11,-4,13,-5,-2},其最大子序列为{11,-4,13},最大和为20。

现在你要找到最大的和,包括最大子序列的第一个和最后一个数。

输入规格:

每个输入文件包含一个测试用例。每个case占用两行。第一行为正整数K(≤10000)。第二行包含K个数字,用空格分隔。

输出规范:

对于每个测试用例,在一行中输出最大的和,以及最大子序列的第一个和最后一个数字。数字之间必须用一个空格隔开,但行末不能有多余的空格。如果最大子序列不是唯一的,则输出索引i和j最小的子序列(如示例案例所示)。如果所有K个数字都是负的,那么它的最大和被定义为0,并且你应该输出整个序列的第一个和最后一个数字。

代码:

#include<iostream>
using namespace std;

const int N = 100000;

int ans[N];
int dp[N];
int max_i = 0;
int max_sum = -999999;

int main()
{
    int n;
    cin >> n;
    int flag = 0;
    for(int i = 1; i <= n; i++){
        cin >> ans[i];
        if(ans[i] > 0) {flag = 1;}
         dp[i]=max(dp[i-1]+ans[i],ans[i]);
           // cout<<dp[i]<<" ";
         if(max_sum < dp[i]){
            max_sum=dp[i];
            max_i = i;
        }
    }
    //cout<<"\n";   
    int start_i = 1;
    int temp = max_sum;
    for(int i = max_i;i > 0 && max_sum > 0; i-- )
    {
        temp = temp - ans[i];
         if(temp == 0){
            start_i = i; 
         }
    }
    
    if(flag == 0){
        max_sum = 0; 
        cout<<max_sum<<" "<<ans[1]<<" "<<ans[n]<<"\n";
    }else{
        cout<<max_sum<<" "<<ans[start_i]<<" "<<ans[max_i]<<"\n";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值