【POJ】2559Largest Rectangle in a Histogram(单调栈求相邻小数)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28376 Accepted: 9165

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

Source

Ulm Local 2003

题目大意:给你N个数就像上面给出的图,我们最终要求出最大的阴影面积

思路:我们容易看出我们最终要求的阴影面积也就是以某个矩形为高其余凑几个底组成的,那么我们就可以找出与某个矩形高度两侧的比他小的矩形的位置,也就是凑底。最终以某个i为高度的矩形阴影面积也就是(R[i]-L[i]-1)*某矩形高度

这个其实求解起来比较像https://blog.csdn.net/wentong_Xu/article/details/86933600这个题目,基本上思路的转换吧可以看一下,最后要求一个最大值的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
#define ll long long
using namespace std;
const int maxn=100010;
int L[maxn],R[maxn];
int a[maxn];
int main()
{
    stack<int>s;
    int n;
    while(scanf("%d",&n)&&n)
    {
        while(!s.empty()) s.pop();
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        a[n+1]=0;
        s.push(0);
        for(int i=1;i<=n+1;i++)
        {
            while(a[s.top()]>a[i])
            {
                R[s.top()]=i;
                s.pop();
            }
            L[i]=s.top();
            s.push(i);
        }
        ll ans=0;
        for(int i=1;i<=n;i++)
            ans=max(ans,(ll)(R[i]-L[i]-1)*a[i]);

        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值