【POJ】1845Sumdiv(数论公式)

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 30080 Accepted: 7412

Description

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).

Input

The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.

Output

The only line of the output will contain S modulo 9901.

Sample Input

2 3

Sample Output

15

Hint

2^3 = 8. 
The natural divisors of 8 are: 1,2,4,8. Their sum is 15. 
15 modulo 9901 is 15 (that should be output). 

Source

Romania OI 2002

题目大意:求所有a^b的所有因子和 

思路:

首先我们知道任意一个数A都可以表示为:

A=(p1^k1)*(p2^k2)………; 其中p为质数

既然都是质数的幂次,那么我们就可以得到因子的和

(1+p1^1+…..p1^k1)*(1+p2^2+…..p2^k2)……………..

那么在其上面加上一个幂次B的时候:

a^b=(p1^k1*b)*(p2^k2*b)…..; 

其中的等比数列的通项公式是需要分类讨论的

详见代码.

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define ll long long
using namespace std;
const int maxn=100010;
int a[maxn];

int main()
{
    int n,m;scanf("%d%d",&n,&m);
    int high=0,low=-1;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        if(a[i]>low)
            low=a[i];
        high+=a[i];
    }

    while(low<high)
    {
        int mid=(low+high)/2;
        int gropnum=1,sum=0;
        for(int i=1;i<=n;i++)
        {
            sum+=a[i];
            if(sum>mid)
            {
                sum=a[i];
                gropnum++;
            }
        }

        if(gropnum<=m)
            high=mid;
        else
            low=mid+1;
    }
    cout<<low<<endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值