hdu 1059 多重背包问题 Dividing

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13188    Accepted Submission(s): 3691


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source
 

Recommend
JGShining


这是一个多重背包的问题,题意是说有有六种石头,价值分别为1,2 , 3 , 4,  5,  6,给其每种数量,问能否分成价值相同的两拨,所以取总价值的一半作为背包容量,看其能否分成价值为背包容量的物品,如果能,就分成了,不能就分不成了。

用多重背包来解决就行了,套用模板,就可以水过了

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[70000];
int sum;
void ZeroOnePack(int cost,int weight)
{
    int v;
    for(v=sum;v>=cost;v--)
     if(dp[v]<dp[v-cost]+weight)
    {
            dp[v]=dp[v-cost]+weight;
    }
}
void CompletePack(int cost,int weight)
{
    int v;
    for(v=cost;v<=sum;v++)
    {
       if(dp[v]<dp[v-cost]+weight)
       dp[v]=dp[v-cost]+weight;
    }
}
void multipack(int cost,int weight,int amount)
{
    int k;
    if(cost*amount>=sum)
    {
        CompletePack(cost,weight);
        return;
    }
    k=1;
    while(k<=amount)
    {
        ZeroOnePack(k*cost,k*weight);
        amount=amount-k;
        k=k*2;
    }
    ZeroOnePack(amount*cost,amount*weight);
}


int main()
{
    int num[6];
    int i;
    int p=1;
    while(scanf("%d%d%d%d%d%d",&num[0],&num[1],&num[2],&num[3],&num[4],&num[5])!=EOF)
    {
        sum=0;
        for(i=0;i<6;i++)
        {
            sum=sum+num[i]*(i+1);
        }
        if(sum==0)
        break;
        if(sum%2==1)
        {
            printf("Collection #%d:\n",p);
            printf("Can't be divided.\n\n");
            p++;
            continue;
        }
        sum=sum/2;
        memset(dp,0,sizeof(dp));
        for(i=0;i<6;i++)
        {
            if(num[i])
            multipack(i+1,i+1,num[i]);
        }
         /*  for(i=0;i<=6;i++)
        {
            printf("dp  %d  dp\n",dp[i]);
        }*/
        if(dp[sum]==sum)
        {
            printf("Collection #%d:\n",p);
            printf("Can be divided.\n\n");
            p++;
        }
        else
        {
            printf("Collection #%d:\n",p);
            printf("Can't be divided.\n\n");
            p++;

        }
    }

    return 0;
}






 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值