Catch That Cow (宽度优先搜索BFS)

题目描述:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: Farmer John can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: Farmer John can move from any point X to the point 2X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入:

Line 1: Two space-separated integers: N and K.

输出:

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

样例输入:

5 17

样例输出:

4

提示:

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int MAXN = 100001;		//此处范围得准确,如果小了会报错

bool visit[MAXN];
int step[MAXN];
queue<int> myQueue;

int bfs(int n, int k)
{
	int next, top;
	myQueue.push(n);			//农夫所在初始点入队
	visit[n] = true;			//标记已被访问
	step[n] = 0;				//步数初始为0
	while(!myQueue.empty()){	//队列非空时,执行循环
		top = myQueue.front();	//取出队首
		myQueue.pop();			//弹出队首
		for (int i = 0; i < 3; i++){
			if (i == 0) {
				next = top - 1;
			} else if (i == 1) {
				next = top + 1;
			} else {
				next = top * 2;
			}
			if(next < 0 || next >= MAXN) continue;	//如已出界,则排除该情况
			if(!visit[next]){						//如果改点还未被访问过
				myQueue.push(next);					//入队
				step[next] = step[top] + 1;			//步数+1
				visit[next] = true;					//标记已被访问过
			}
			if(next == k) return step[next];		//当遍历到结果,返回步数
		}
	}
}

int main()
{
	int n, k;
	cin >> n >> k;
	memset(visit, false, sizeof(visit));
	if (n >= k) 
		printf("%d\n", n - k);
	else 
		printf("%d\n",bfs(n,k));
	return 0;
}
        
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值