(2)I - Safecracker

=== Op tech briefing, 2002/11/02 06:42 CST ===
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Output
LKEBA
YOXUZ
GHOST
no solution
Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Sample Output
LKEBA
YOXUZ
GHOST
no solution
题意:输入target ABC.. 其中ABC..表示123...,方程v-w^2+x^3-y^4+z^5=target,输出最大的字典序的vwyz。思路:先排序,再递归查找
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
int use[15];
int target,len,flag;
char a[15],b[6];
void dfs(int n);
bool cmp(char x,char y)
{
 return x>y;
}
int main()
{
 int i,j;
 while(cin>>target>>a&&target)
 {
  flag=0;
  memset(use,0,sizeof(use));
  len=strlen(a);
  sort(a,a+len,cmp);//排序 
  dfs(0);//递归查找 
  if(flag)
  {
   cout<<b<<endl;
  }
  else
  {
   cout<<"no solution"<<endl;
  }
 }
}
void dfs(int n)
{
 int i,j,x1,x2,x3,x4,x5,sum;
 
 if(n==5)
 {
  x1=b[0]-'A'+1,x2=b[1]-'A'+1,x3=b[2]-'A'+1,x4=b[3]-'A'+1,x5=b[4]-'A'+1;
  sum=x1-x2*x2+x3*x3*x3-x4*x4*x4*x4+x5*x5*x5*x5*x5;
  if(target==sum)
  {
   flag=1;
  }
  return;
 }
 else
 {
  for(i=0;i<len;i++)
  {
   if(use[i]==0)
   {
    b[n]=a[i];
    use[i]=1;
    dfs(n+1);
    if(flag)
    {
     return;
    }
    use[i]=0; 
   }
   
  }
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值