B - Piggy-Bank ( 完全背包问题(求最小值时,一维dp[ ] 的精确使用)(无限制次数的选择同一个物件时,就是完全背包问题)

B - Piggy-Bank

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

for(int i=1; i<=num2; i++)//循环一边,选和不选都min了一遍
        {
            for(int v=volume[i]; v<=m; v++)//设 f[v]表示重量不超过v公斤的最小价值
            {
                                                            //这里是v++ 顺序 区别于01背包
                dp[v] = min( dp[ v-volume[i] ] + value[i], dp[v]);
            }
        }
 

//从小到大,从小到大是叠加的过程,也就是从多次选择同一个最小的类型,逐渐叠加,到整体的最小值时,相当于叠加了很多个一样大小空间类型的物件,这就是完全背包问题!!!!!!!!!!!!!!!!!(只要是可以多!!多!!多!!无限制次数的选择同一个物件时,就是完全背包问题)

 

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include<stdio.h>
using namespace std;

int value[50006],volume[10000];
int dp[10006];
const int inf=0x3f3f3f3f;

//int dp[1006];
//int value[1006];
//int volume[1006];

int main()
{
    int num1,x,y,m,num2;
    cin>>num1;
    while(num1--)
    {
        cin>>x>>y;
        m=y-x;
        cin>>num2;

        memset(value,0,sizeof(value));
        memset(volume,0,sizeof(volume));
        memset(dp,inf,sizeof(dp));//因为要求最小值,初始值为最大值
        dp[0]=0;//无论是怎么样的背包问题,当不存在空间时,都只能是价值0
        for(int i=1; i<=num2; i++)
        {
            cin>>value[i]>>volume[i];
        }
        for(int i=1; i<=num2; i++)
        {
            for(int v=volume[i]; v<=m; v++)//设 f[v]表示重量不超过v公斤的最大价值
            {
                //这里是v++ 顺序 区别于01背包
                dp[v] = min( dp[ v-volume[i] ] + value[i], dp[v]);
            }
        }
        if(dp[m]==inf)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[m]);
    }

    return 0;
}

 

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值