POJ--2676&HDU--1421(数独,dfs)

Time Limit: 2000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843

854396127

用三个数组分别记录每行、列、格子出现过的数字,然后进行dfs即可

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
#include<cstdlib>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxd=10+5;
typedef long long ll;
int dx[]= {0,0,1,-1};
int dy[]= {1,-1,0,0};
//====================
int mz[maxd][maxd],visr[maxd][maxd],visc[maxd][maxd],grid[maxd][maxd];
char m[maxd][maxd];
void init()
{
    mem(visr,0),mem(visc,0),mem(grid,0);
    for(int i=0; i<9; ++i)
    {
        scanf("%s",m[i]);
        for(int j=0; j<9; ++j)
        {
            mz[i][j]=m[i][j]-'0';
            visr[i][mz[i][j]]=1;
            visc[j][mz[i][j]]=1;
            int tmp=i/3*3+j/3;
            grid[tmp][mz[i][j]]=1;
        }
    }
}

bool dfs(int x,int y)
{
    // if(!setnum(x,y)) return;
    if(x==9) return true;
    bool flag=false;
    if(mz[x][y]==0)
    {
        int tmp=x/3*3+y/3;
        for(int i=1; i<=9; ++i)
            if(visr[x][i]==0 && visc[y][i]==0 && grid[tmp][i]==0)
            {
                mz[x][y]=i;
                visr[x][i]=1;
                visc[y][i]=1;
                grid[tmp][i]=1;
                if(y==8)
                    flag=dfs(x+1,0);
                else
                    flag=dfs(x,y+1);

                if(flag) return true;
                else
                {
                    mz[x][y]=0;
                    visr[x][i]=0;
                    visc[y][i]=0;
                    grid[tmp][i]=0;
                }
            }
    }
    else
    {
        if(y==8)
            flag=dfs(x+1,0);
        else
            flag=dfs(x,y+1);

        if(flag) return true;
        else return false;
    }
    return false;
}

void print(int k)
{
    printf("Scenario #%d:\n",k);
    for(int i=0; i<9; ++i)
    {
        for(int j=0; j<9; ++j)
            printf("%d",mz[i][j]);
        printf("\n");
    }
    printf("\n");
}

int main()
{
    freopen("1.txt","r",stdin);
    int kase;
    scanf("%d",&kase);
    for(int k=1;k<=kase;++k)
    {
        init();
        dfs(0,0);
        print(k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值