How far away ? HDU - 2586

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases. 
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n. 
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

题意:给你一个无向图,有m次查询,查询点x与点y之间的最短距离。

思路:LCA模板题,dis[x]表示x到根节点的最短距离,那么点x与点y之间的最短距离=dis[x]+dis[y]-2*dis[lca(x,y)];

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=40009;
int head[maxn],cnt,dis[maxn],dep[maxn],f[maxn][30],n,m;
struct node{
	int id;
	int val;
	int next;
}side[maxn*2];
void add(int x,int y,int d)
{
	side[cnt].id=y;
	side[cnt].val=d;
	side[cnt].next=head[x];
	head[x]=cnt++;
}
void dfs(int x,int fa)
{
	for(int i=head[x];i!=-1;i=side[i].next)
	{
		int y=side[i].id;
		if(y==fa) continue;
		f[y][0]=x;
		dis[y]=dis[x]+side[i].val;
		dep[y]=dep[x]+1;
		dfs(y,x);
	}
}
void init()
{
	memset(head,-1,sizeof(head));
	memset(dep,0,sizeof(dep));
	memset(f,0,sizeof(f));
	dis[1]=0;
	cnt=0;
}
void need()
{
	for(int j=1;(1<<j)<=n;j++)
		for(int i=1;i<=n;i++)
			f[i][j]=f[f[i][j-1]][j-1];
}
int lca(int a,int b)
{
	if(dep[a]>dep[b])
		swap(a,b);
	int ff=dep[b]-dep[a];
	for(int i=0;(1<<i)<=ff;i++)
		if((1<<i)&ff)
			b=f[b][i];
	if(a!=b)
	{
		for(int i=(int)(log2(n));i>=0;i--)
		if(f[a][i]!=f[b][i])
		{
			a=f[a][i];
			b=f[b][i];
		}
		a=f[a][0];
	}
	return a;
}
int main()
{
	int t,x,y,z;
	scanf("%d",&t);
	while(t--)
	{
		init();
		scanf("%d%d",&n,&m);
		for(int i=1;i<n;i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			add(x,y,z);
			add(y,x,z); 
		}
		dfs(1,-1);
		need();
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			int ff=lca(x,y);
		//	printf("%d**%d**%d\n",dis[x],dis[y],ff);
			int ans=dis[x]+dis[y]-2*dis[ff];
			printf("%d\n",ans);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值