hdu Reward(拓扑排序)

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1803    Accepted Submission(s): 525


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 

Author
dandelion
 

Source
 

Recommend
yifenfei

题目本身没有什么好多说的,因为数据范围很大,用邻接矩阵做空间不够,所以用邻接表
第一次用vector做邻接表,还是记录一下

#include <stdio.h>
#include <string.h>
#include <vector>
using namespace std;

int n;
int indegree[10005];
vector <int>  v[10005];

int topsort(){
    int i,j,tag;
    int countn = 0,q = 0;
    int tem[10005];
    int sum = n * 888;

    while(countn != n){
        tag = 0;
        for(i = 1;i <= n;i++){
            if(!indegree[i]){
                indegree[i] = -1;
                tem[tag] = i;
                tag++;
            }
        }
        if(!tag){
            return -1;
        }
        else{
            sum += q * tag;
            q++;
            countn += tag;
            for(i = 0;i < tag;i++){
                for(j = 0;j < v[tem[i]].size();j++){
                    indegree[v[tem[i]].at(j)]--;
                }
            }
        }
    }
    return sum;
}
int main(){
    int m;
    int i,j;
    int a,b;

    while(scanf("%d%d",&n,&m) != EOF){
        for(i = 0;i < 10005;i++)
            v[i].clear();
        memset(indegree,0,sizeof(indegree));
        while(m--){
            scanf("%d%d",&a,&b);
            int flag = 0;
            for(i = 0;i < v[b].size();i++){
                if(v[b].at(i) == a)
                    flag = 1;
            }
            if(!flag){
                indegree[a]++;
                v[b].push_back(a);
            }
        }
        printf("%d\n",topsort());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值