20140714 「初等数论 - 拓展欧几里得+同余模方程」POJ 2115 C Looooops

10 篇文章 0 订阅

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
wilson1068      Log Out
Mail:0(0)
Login Log      Archive
Language:
C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16982 Accepted: 4386

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator




数论:拓展欧几里得 + 同余模方程模板一份。

题解嘛,有空再补。。。(其实就是模板题。)




#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

typedef long long LL;

LL ext_gcd(LL a, LL b, LL &x, LL &y){         
	if( 0==b ){	x=1; y=0;	return a;	}
	LL d = ext_gcd(b, a%b, x, y);
	LL t = x;
	x = y;
	y = t - (a/b)*y;
	return d;
}

LL MLES(LL a, LL b, LL n){
	LL d, x, y;
	d = ext_gcd(a, n, x, y);			/* d's solve. */
	if( b%d )   return -1;
	LL x0 = x*(b/d) % n;
	return  (x0%(n/d)+n/d)%(n/d);
}

int main(){               freopen("2115.in", "r", stdin);
    LL A, B, C, k;
    while( cin>>A>>B>>C>>k ){
        if( 0==A+B+C+k )
            break;
        LL n=(LL)1<<k, a=C, b=(B-A+n)%n;
        LL ans = MLES(a, b, n);
        if( -1==ans )   cout<<"FOREVER"<<endl;
        else            cout<<ans<<endl;
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值