20140715 「博弈 - Nim(尼姆)博弈」 HDOJ 1907 John

9 篇文章 0 订阅

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
STD Contests 
VIP Contests 
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2734    Accepted Submission(s): 1517


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
      
      
2 3 3 5 1 1 1
 

Sample Output
      
      
John Brother
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1913  1908  1914  1915  1909 
 

Statistic |  Submit |  Discuss |  Note
Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2014 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.003341(s) query 5, Server time : 2014-07-15 17:45:19, Gzip enabled









博弈:尼姆博弈 模板一份

题解嘛,有空再补。。。








#include <stdio.h>
#define MAXN 4888
int main(){			//freopen("John.in","r",stdin);
	int a[MAXN], T, n;
	while( ~scanf("%d", &T) ){
		while( T-- && ~scanf("%d", &n) ){
			int sum = 0, ans = 0;
			for(int i=0; i<n; i++){
				scanf("%d", &a[i]);
				sum ^= a[i];
				if( a[i]>1 )	ans = 1;
			}
			if( ans )	printf("%s\n", sum ? "John":"Brother");
			else		printf("%s\n", n&1 ? "Brother":"John");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值