(hdu 1907)John (Misère Nim,Nim博弈的变形)

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input
2
3
3 5 1
1
1
Sample Output
John
Brother

Misère Nim
当最后取的人为败者时,有如下结论:
(1)当所有石子堆都为一时,奇数堆必败,偶数堆必胜
(2)当仅有一堆石子数大于一时,为必胜态。为了保证还剩下奇数堆,可以选择拿光这一堆还是留一个。
(3)当有超过一堆石子数大于一时,将各堆石子数求Nim和,若结果为0则必败,否则必胜。
注意(2)和(3)可以合并,直接求Nim和判定胜负。在(3)局面的获胜办法和常规nim博弈一样,直至进入(2)。
如果你采用最优策略,至少有两堆大于一,否则无法保证nim和为0让对手必败。同样对手无法把两堆大于一的石子同时拿成为石子都为一的两堆,所以必然进入(2)。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
const double INF=0x3f3f3f3f+1.0;
const double eps=1e-6;
const double PI=2.0*acos(0.0);
typedef long long LL;
const int N=55;
int a[N];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int ans=0,num=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            ans^=a[i];
            if(a[i]>1) num++;
        }
        if(num==0)
            printf("%s\n",ans?"Brother":"John");
        else printf("%s\n",ans?"John":"Brother");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值