1076 Forward on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

解题思路:一道广搜的题目,还算简单,就是根据题目输入记录下每个编号的用户的粉丝,这个跟题目的输入有点不一样的,题目给的是每个编号的用户关注的人的编号。查询的时候,从查询的用户编号开始,广搜,中间记录一下层的深度,超过规定深度L的就不用计算了。
最后一个点应该是很多重复计算的用户的测试用例,因为一开始我的代码最后一个点一直内存超限,因为在遍历的时候没有判断重复,不断的就放到vector中,后来直接在遍历的过程中进行时候访问过的判断就过了。

#include<iostream>
#include<vector>
#include<set>
#include<string.h>
using namespace std;
int n, l;
vector<int>* followed;
int flag[1005];
int getTriger(int s){
    memset(flag, 0, sizeof(flag));
    int res = 0;
    int levelCount = 0;
    vector<int>vec;
    vec.push_back(s);
    while (levelCount < l && (vec.size() > 0)){
        vector<int>temp;
        for (int i = 0; i < vec.size(); i++){
            for (int j = 0; j < followed[vec[i]].size(); j++){
                if (followed[vec[i]][j] != s){

                    if (flag[followed[vec[i]][j]] == 0){
                        res++;
                        flag[followed[vec[i]][j]] = 1;
                        temp.push_back(followed[vec[i]][j]);
                    }
                }
            }
        }
        vec.clear();
        vec = temp;
        levelCount++;
    }
    return res;
}
int main(){
    for (; scanf("%d%d", &n, &l) != EOF;){
        followed = new vector<int>[n + 1];
        for (int i = 0; i <= n; i++){
            followed[i] = vector<int>();
        }
        for (int i = 1; i <= n; i++){
            int size;
            scanf("%d", &size);
            while (size--){
                int temp;
                scanf("%d", &temp);
                followed[temp].push_back(i);
            }
        }
        int k;
        scanf("%d", &k);
        while (k--){
            int temp;
            scanf("%d", &temp);
            printf("%d\n", getTriger(temp));
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值