http://acm.hdu.edu.cn/showproblem.php?pid=2131
Probability
Time Limit: 3000/1000 MS (Java/Others)
Total Submission(s): 2510
Problem Description
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
Output
For each test case, print the probability rounded to five digits after the decimal point.
Sample Input
a apple c Candy a banana
Sample Output
0.20000 0.20000 0.50000
Author
KiKi
Source
Recommend
威士忌
分析:小小的水题,A之 ^-^
代码如下:
#include<stdio.h>
#include<string.h>
int main()
{
char c,w[201];
int l,i,count;
while(scanf("%c %s",&c,w)!=EOF)
{
count=0;
l=strlen(w);
if(c<97)
c=c+32;
for(i=0;i<l;i++)
{
if(w[i]==c||w[i]+32==c)
count++;
}
printf("%.5lf\n",(double)count/l);
getchar();
}
return 0;
}
#include<string.h>
int main()
{
}