HDU 1323 Perfection

http://acm.hdu.edu.cn/showproblem.php?pid=1323

 

Perfection

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 830 Accepted Submission(s): 504


Problem Description
From the article Number Theory in the 1994 Microsoft Encarta: "If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."
Given a number, determine if it is perfect, abundant, or deficient.


 

Input
A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.


 

Output
The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.


 

Sample Input
15 28 6 56 60000 22 496 0


 

Sample Output
PERFECTION OUTPUT 15 DEFICIENT 28 PERFECT 6 PERFECT 56 ABUNDANT 60000 ABUNDANT 22 DEFICIENT 496 PERFECT END OF OUTPUT


 

Source


 

Recommend
Ignatius.L
 
题目大意:求一个数的真因子之和,大于这个数叫ABUNDANT,小于叫DEFICIENT,等于叫PERFECT。
代码如下:
#include<iostream>
#include<math.h> 
using namespace std;     
int fun(int);          //求一个数的真因子之和
int main()

  int n,ans;
        cout<<"PERFECTION OUTPUT"<<endl;
  while(cin>>n)
  {
    if(n==0)
    {
      cout<<"END OF OUTPUT"<<endl;
      break;
    }
    ans=fun(n);
    printf("]  ",n);
    if(ans==n) cout<<"PERFECT"<<endl;
    else if(ans<n) cout<<"DEFICIENT"<<endl;
    else cout<<"ABUNDANT"<<endl;
  }
    return 0;
}
int fun(int n)
{
    int i,sum=0;
    for(i=2;i<=n/2;i++)
      if(n%i==0)
        sum+=i;
      return sum+1;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值