暑期集训之pie

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different. 
Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends. 
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies. 
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

题解:这道题的大致意思是每个人分到的面积一样的话求出这个面积的最大的那一个(因为题目说了Pie的高度是1,所以面积等于体积)

运用到了二分的思想,注意,这道题设有精度这一说,所以要考虑精度问题

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define PI acos(-1.0) 
using namespace std;
double ri[10005];
int n,k;
bool check(double t)//这个函数其实是求在输入的这几个pie中,按着t大小分配pie的话能否满足所有人都能吃到t大小的pie,满足就true,否则false 
{
	int ans=0;
	for(int i=0;i<n;i++)
	{
		ans+=(int)(ri[i]/t);//ans就是每个pie能分成t大小pie的个数之和 
	 	if(ans>=k)//一旦出现Pie的数目大于等于到场人数的话就true 
	return true;
}
	return false;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		double l,r,mid;
		l=0.0;
		r=0.0;
		scanf("%d%d",&n,&k);
		k++;//k的原来数值只是朋友的个数,而主人公也是一员,所以加1,加上主人公 
		for(int i=0;i<n;i++)
		{
			scanf("%lf",&ri[i]);
			ri[i]=ri[i]*ri[i]*PI;//这里是直接把所输入的半径变量变成面积,方便下面计算 
			r=max(r,ri[i]);//这里是吧右边界给设成pie里面的最大的那一个 
		 }
		 while(r-l>0.00001) //这里就是精度的设置问题了,按着题目中的要求来写,有精度的模板和没精度的模板有着很大不同,要牢记 
		 {
		 	mid=(r+l)/2.0;//二分思想的体现,找出最大和最小中间的那个数值 
		 	if(check(mid))//如果返回值为真,那么代表 我们可以用此时mid的大小来替换左边界,看是否存在比mid还大但仍然满足所有人都能吃到一样大小的pie,因为题目上说的是尽可能大 
		 	{
		 		l=mid;
			  } 
			  else//一旦发现不符合的话,此时mid的大小就得替换掉右边界,继续在比mid小的大小里面找符合题目条件的大小 
			  r=mid;
		 }
		 printf("%.4lf\n",l);//最后输出l,因为只有满足条件的时候l的值才变,所以对于l来说,它是永远符合题目条件的那个值 
	}
	return 0;
}






  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值