【PAT】甲级1013 - Battle Over Cities(并查集)

题目链接:点击打开题目


  1. Battle Over Cities (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0


题意:给出一张图,问去掉某个城市,要把剩下的图连起来,需要几条边。


题解:直接并查集连图,然后搜根节点的数量就行。


代码如下:

#include<map>
#include<queue>
#include<cmath>
#include<stack>
#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
#define INF 0x3f3f3f3f
#define CLR(a,b) memset(a,b,sizeof(a))
#define PI acos(-1.0)
#define fi first
#define se second
vector<pair<int,int> > edge;
int f[1005];
int n,m;
int find(int x)
{
    if (x != f[x])
        f[x] = find(f[x]);
    return f[x];
}
void join(int x,int y)
{
    int fx,fy;
    fx = find(x);
    fy = find(y);
    if (fx != fy)
        f[fx] = fy;
}
void solve(int p)
{
    for (int i = 1 ; i <= n ; i++)      //记得初始化 
        f[i] = i;
    for (int i = 0 ; i < edge.size() ; i++)
    {
        if (edge[i].fi == p || edge[i].se == p)
            continue;
        join(edge[i].fi,edge[i].se);
    }
    int cnt = 0;
    bool vis[1005] = {false};
    for (int i = 1 ; i <= n ; i++)
    {
        if (i == p) 
            continue;
        int fx = find(i);
        if (!vis[fx])
        {
            vis[fx] = true;
            cnt++;
        }
    }
    cout << cnt-1 << endl;
}
int main()
{
    int k;
    cin >> n >> m >> k;
    edge.resize(m);
    for (int i = 0 ; i < m ; i++)
    {
        int x,y;
        cin >> x >> y;
        edge[i] = make_pair(x,y);
    }
    for (int i = 1 ; i <= k ; i++)
    {
        int q;
        cin >> q;
        solve(q);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值