Problem C: 动态规划基础题目之数字三角形

Problem C: 动态规划基础题目之数字三角形


Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

eg1.

#include<stdio.h>
int main()
{
    int n,a[99][99],i,j,m;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        for(j=0;j<=i;j++)
        {
            scanf("%d",&a[i][j]);
        }
    }
    for(i=n-1;i>1;i--)
    {
        for(j=0;j<i;j++)
        {
            a[i-1][j]+=(a[i][j]>a[i][j+1]?a[i][j]:a[i][j+1]);// Dynamic transfer equation from bottom to top
        }
    }
    printf("%d",a[0][0]+(a[1][0]>a[1][1]?a[1][0]:a[1][1]));
    return 0;
}

eg2.

#include<stdio.h>
#include<stdlib.h>
int max(int a,int b);
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,m,i,j,k;
    int a[99][99],b[99][99];
    memset(b,0,sizeof(b));
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        for(j=0;j<=i;j++)
        {
            scanf("%d",&a[i][j]);
            if(i==n-1)
            {
                b[i][j]=a[i][j];
            }
        }
    }
    for(i=n-2;i>=0;i--)
    {
        for(j=0;j<=i;j++)
        {
            b[i][j]=a[i][j]+max(b[i+1][j],b[i+1][j+1]);//find the biggest.
        }
    }
    printf("%d",b[0][0]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Loganer

感谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值