hd1312

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 
Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 
Sample Output
  
  
45 59 6 13
 
题目大意就是一二位字符数组,从制定位置即@这里开始,只能走其上下左右四个方向且只有这个字符'.'时才可以走,问可以走的总步数。
 
这题深搜,代码不长,不造为啥感觉我的意思都对,运行结果老不对,然后我就改,,,,一直改,改到我已无力再改时,我自己都不知道我到底改了什么,然后它ac了。。。。(其实代码的总体还是没怎么改,感觉和之前的一样。。。。)不说了,,,,都是泪啊。。。。
 
//深搜
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

char map[21][21];
int row,col,s;

void dfs(int a,int b)
{
	int i,x,y;
	int move[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
	for(i=0;i<4;++i)
	{
		x=a+move[i][0];
		y=b+move[i][1];
		if(x<row&&x>=0&&y<col&&y>=0&&map[x][y]=='.')
		{
			s++;
			map[x][y]='#';                          
			dfs(x,y);
		}
	}
}

int main()
{
	int i,j,x,y;
	while(scanf("%d%d",&col,&row))
	{
		if(col==0||row==0)break;
		for(i=0;i<row;++i)
		    scanf("%s",map[i]);
		for(i=0;i<row;++i)
		{
			for(j=0;j<col;++j)
			{
				if(map[i][j]=='@')
		        {
		        	x=i;y=j;
		        }
			}
		}
		s=1;
	    dfs(x,y);
		printf("%d\n",s);
	}
	return 0;
}
 
我就是没事找事.....
//广搜
 
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

char map[21][21];
int row,col,s;
struct node 
{
	int x,y;
};

void bfs(int a,int b)
{
	int i,move[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
	node ss,now,next;
	queue<node>q;
	ss.x=a;
	ss.y=b;
	s=1;
	q.push(ss);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(i=0;i<4;++i)
		{
			next.x=now.x+move[i][0];
			next.y=now.y+move[i][1];
			if(next.x<row&&next.x>=0&&next.y<col&&next.y>=0&&map[next.x][next.y]=='.')
			{
				s++;
				map[next.x][next.y]='#';
				q.push(next);
			}
		}
	}
}

int main()
{
	int i,j,x,y;
	while(~scanf("%d%d",&col,&row))
	{
		if(col==0||row==0)break;
		for(i=0;i<row;++i)
		    scanf("%s",map[i]);
		for(i=0;i<row;++i)
		{
			for(j=0;j<col;++j)
			{
				if(map[i][j]=='@')
				{
					x=i;y=j;
				}
			}
		}
		bfs(x,y);
		printf("%d\n",s);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值