hd2674 N!Again

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!
 
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 
Output
For each case, output N! mod 2009
 
Sample Input
  
  
4 5
 
Sample Output
  
  
24 120
恩,题目大意就是求n!对2009取余,同余定理(a*b)%c=((a%c)*(b%c))%c;
2009=7*7*41;因为是n的阶乘,所以当n>=41是就都为0了
呃,当时做的时候,楞是忘了是n的阶乘取余,结果代码敲出来之后测试1000为0以为错了就没提交,其实。。。当时是对的!!!
#include<stdio.h>
int main()
{
	int n,ans,i;
	while(scanf("%d",&n)==1)
	{
		ans=1;
		if(n<44)
		{
			for(i=1;i<=n;++i)
			{
				ans=(ans*(i%2009))%2009;
			}
		}
		else ans=0;
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值