杭电1242 Rescue

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20846    Accepted Submission(s): 7446

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 
Input
First line contains two integers stand for N and M.
Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.
Process to the end of the file.
 Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 
Sample Output
  
  
13
 
恩,题目大意就是说,a代表要救的人,r代表初始位置,#为墙,x为士兵,可以往四个方向走,每走一步花费一分钟然后遇到士兵并杀死士兵花费2分钟,问救到人最少花费多久时间。广搜,优先队列。
#include<stdio.h>
#include<string.h>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
struct node 
{
	int x,y,time;
	friend bool operator < (node a,node b)
	{
		return a.time > b.time;
	}
};
int n,m;
char map[220][220];
int vis[220][220];
int rec[220][220];
int dir[4][2]={-1,0,1,0,0,-1,0,1};
//int dir[4][2]={-1,0,0,-1,0,1,1,0};看讨论区里说这种方向不过,就试了一下,真的哎,过了呢 
int judge(int x,int y)
{
	if(!vis[x][y]&&map[x][y]!='#'&&x>=0&&x<n&&y>=0&&y<m)
		return 1;
	return 0;
}
void bfs(int fx,int fy)
{
	node ss,now,next;
	ss.x=fx;
	ss.y=fy;
	ss.time=0;
	vis[fx][fy]=1;
	priority_queue<node>q;
	q.push(ss);
	while(!q.empty())
	{
		now=q.top();
		q.pop();
		if(map[now.x][now.y]=='a')
		{
			printf("%d\n",now.time);
			return ;
		}
		for(int i=0;i<4;++i)
		{
			next.x=now.x+dir[i][0];
			next.y=now.y+dir[i][1];
			if(judge(next.x,next.y))
			{
				next.time=now.time+1;
				if(map[next.x][next.y]=='x')
					next.time++;
				vis[next.x][next.y]=1;
//				if(next.time>rec[next.x][next.y])
//					continue;
//				rec[next.x][next.y]=next.time;
				q.push(next);
			}
		}
	}
	printf("Poor ANGEL has to stay in the prison all his life.\n");	
}
int main()
{
	int fx,fy;
	while(~scanf("%d %d",&n,&m))
	{
		memset(map,0,sizeof(map));
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;++i)
			scanf("%s",map[i]);
		for(int i=0;i<n;++i)
		{
			for(int j=0;j<n;++j)
			{
				rec[i][j]=INF;
				if(map[i][j]=='r')
				{
					fx=i;
					fy=j;
				}
			}
		}
		bfs(fx,fy);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值