poj 3620 Avoid The Lakes

Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7027 Accepted: 3738

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

 

恩,题目大意就是说求最大的湖的大小。题目给三个数代表农场的行,列,以及带水的地方的个数,下面是有水的地方的坐标,然后相连的有水的地方为一个大湖泊,这里找最大的湖泊所包含的小湖泊的个数。深搜。记录最大值。
#include<cstdio>
#include<cstring>
int map[110][110];
int n,m,cnt;
int dirx[4]={0,1,-1,0};
int diry[4]={1,0,0,-1};
void dfs(int r,int c)
{
	int nr,nc;
	if(r<=0||r>n||c<=0||c>m)
		return ;
	if(map[r][c]!=1)
		return ;
	cnt++;
	map[r][c]=0;
	for(int i=0;i<4;++i)
	{
		nr=r+dirx[i];
		nc=c+diry[i];
		dfs(nr,nc);
	}
}
int main()
{
	int k,r,c,max;
	while(~scanf("%d%d%d",&n,&m,&k))
	{
		max=-1;
		memset(map,0,sizeof(map));
		while(k--)
		{
			scanf("%d%d",&r,&c);
			map[r][c]=1;
		}
		for(int i=1;i<=n;++i)
		{
			for(int j=1;j<=m;++j)
			{
				if(map[i][j]==1)
				{
					cnt=0;
					dfs(i,j);
					if(cnt>max)
						max=cnt;
				}
			}
		}
		printf("%d\n",max);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值