HDU 2647 Reward 【逆拓扑】

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5633    Accepted Submission(s): 1710


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 


 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 


 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 


 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 


 

Sample Output
  
  
1777 -1

 

嗯,这个题刚好是反着的,a指向b,但是a的工资要比b高,所以邻接表建立时反着来就OK了

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 10010
using namespace std;
int cnt,num,in[maxn],head[maxn],sum[maxn];
queue<int>q;
struct node
{
    int a,b,next;
};
node edge[maxn*2];
void add(int a,int b)
{
    edge[cnt].a=a;
    edge[cnt].b=b;
    edge[cnt].next=head[a];
    head[a]=cnt;
    cnt++;
}
void top_sort()
{
    int u,v;
    while(!q.empty())
    {
        num++;
        u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            v=edge[i].b;
            in[v]--;
            sum[v]=sum[v]>sum[u]+1?sum[v]:sum[u]+1;
            if(in[v]==0)
            {
                in[v]=-1;
                q.push(v);
            }
        }
    }
}
int main()
{
    int n,m,a,b;
    while(~scanf("%d%d",&n,&m))
    {
        cnt=num=0;
        memset(in,0,sizeof(in));
        memset(head,-1,sizeof(head));
        for(int i=1;i<=n;++i)
            sum[i]=888;
        for(int i=0;i<m;++i)
        {
            scanf("%d%d",&a,&b);
            add(b,a);
            in[a]++;
        }
        for(int i=1;i<=n;++i)
        {
            if(in[i]==0)
            {
                in[i]=-1;
                sum[i]=888;
                q.push(i);
            }
        }
        top_sort();
        int s=0;
        if(num!=n)
            printf("-1\n");
        else
        {
            for(int i=1;i<=n;++i)
                s+=sum[i];
            printf("%d\n",s);
        }
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值