HDU 4324 Triangle LOVE 【拓扑排序】

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3494    Accepted Submission(s): 1356


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 


 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 


 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 


 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 


 

Sample Output
  
  
Case #1: Yes Case #2: No

 

嗯,题目大意就是说,个人认为判断是否能成环吧,若能,则topsort查找到最后一定存在入度不为0 的点,若不能,则一定不存在入度不为0的点

 

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define maxn 2020
using namespace std;
int cnt,flag,head[maxn],in[maxn];
queue<int>q;
struct node
{
    int a,b,next;
};
node edge[maxn*maxn];
void add(int a,int b)
{
    edge[cnt].a=a;
    edge[cnt].b=b;
    edge[cnt].next=head[a];
    head[a]=cnt;
    cnt++;
}
void top_sort()
{
    int u,v;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            v=edge[i].b;
            in[v]--;
            if(in[v]==0)
            {
                in[v]=-1;
                q.push(v);
            }
        }
    }
}
int main()
{
    int t,n,num=0;
    char s[maxn];
    scanf("%d",&t);
    while(t--)
    {
        num++;
        cnt=flag=0;
        memset(in,0,sizeof(in));
        memset(head,-1,sizeof(head));
        while(!q.empty())
            q.pop();
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",s);
            for(int j=0;j<n;++j)
            {
                if(s[j]=='1')
                {
                    add(i,j);
                    in[j]++;
                }
            }
        }
        for(int i=0;i<n;++i)
        {
            if(in[i]==0)
            {
                in[i]=-1;
                q.push(i);
            }
            top_sort();
        }
        for(int i=0;i<n;++i)
        {
            if(in[i]!=-1)
            {
                flag=1;
                break;
            }
        }
        printf("Case #%d: ",num);
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值