ZOJ 2853 Evolution【矩阵快速幂】

Evolution

Time Limit: 5 Seconds      Memory Limit: 32768 KB

Evolution is a long, long process with extreme complexity and involves many species. Dr. C. P. Lottery is currently investigating a simplified model of evolution: consider that we have N (2 <= N <= 200) species in the whole process of evolution, indexed from 0 to N -1, and there is exactly one ultimate species indexed as N-1. In addition, Dr. Lottery divides the whole evolution process into M (2 <= M <= 100000) sub-processes. Dr. Lottery also gives an 'evolution rate' P(i, j) for 2 species i and j, where i and j are not the same, which means that in an evolution sub-process, P(i, j) of the population of species i will transform to species j, while the other part remains unchanged.

Given the initial population of all species, write a program for Dr. Lottery to determine the population of the ultimate species after the evolution process. Round your final result to an integer.

Input

The input contains multiple test cases!

Each test case begins with a line with two integers N, M. After that, there will be a line with N numbers, indicating the initial population of each species, then there will be a number T and T lines follow, each line is in format "i j P(i,j)" (0 <= P(i,j) <=1).

A line with N = 0 and M = 0 signals the end of the input, which should not be proceed.

Output

For each test case, output the rounded-to-integer population of the ultimate species after the whole evolution process. Write your answer to each test case in a single line.

Notes

  • There will be no 'circle's in the evolution process.
  • E.g. for each species i, there will never be a path i, s1, s2, ..., st, i, such that P(i,s1) <> 0, P(sx,sx+1) <> 0 and P(st, i) <> 0.
  • The initial population of each species will not exceed 100,000,000.
  • There're totally about 5 large (N >= 150) test cases in the input.

Example

Let's assume that P(0, 1) = P(1, 2) = 1, and at the beginning of a sub-process, the populations of 0, 1, 2 are 40, 20 and 10 respectively, then at the end of the sub-process, the populations are 0, 40 and 30 respectively.

Sample Input

2 3
100 20
1
0 1 1.0
4 100
1000 2000 3000 0
3
0 1 0.19
1 2 0.05
0 2 0.67
0 0

Sample Output

120
0

恩,题意大致是,物种的进化,共n个物种,从0到n-1编号,然后第n-1个物种为终极进化物种,然后p[i,j]表示从i 进化到 j 的进化率,即,占p[i,j]百分比的i 物种会进化为 j 物种,剩下的仍为 i 物种,问最终第n-1 个物种有多少数量。相当于第j 个物种多了 i 物种初始个数的p 百分比,i 物种自身少了其初始数据的p百分比


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 220
using namespace std;
int n,m;
double num[maxn];
struct Mmat
{
    double mat[maxn][maxn];
};
Mmat s;
Mmat operator * (Mmat a,Mmat b)
{
    Mmat c;
    memset(c.mat,0,sizeof(c.mat));
    for(int k=0;k<n;++k)
    {
        for(int i=0;i<n;++i)
        {
            if(a.mat[i][k]<=0)
                continue;
            for(int j=0;j<n;++j)
            {
                if(b.mat[k][j]<=0)
                    continue;
                c.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
            }
        }
    }
    return c;
}
Mmat operator ^ (Mmat a,int k)
{
    Mmat c;
    memset(c.mat,0,sizeof(c.mat));
    for(int i=0;i<n;++i)
        c.mat[i][i]=1.0;
    while(k)
    {
        if(k&1)
            c=c*a;
        a=a*a;
        k=k>>1;
    }
    return c;
}
int main()
{
    int t,a,b;
    double p;
    while(scanf("%d%d",&n,&m)&&(n||m))
    {
        for(int i=0;i<n;++i)
        {
            for(int j=0;j<n;++j)
                s.mat[i][j]=(i==j);
        }
        for(int i=0;i<n;++i)
            scanf("%lf",num[i]);
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d%lf",&a,&b,&p);
            s.mat[a][b]+=p;
            s.mat[a][a]-=p;
        }
        s=s^m;
        double ans=0;
        for(int i=0;i<n;++i)
            ans+=num[i]*s.mat[i][n-1];
        printf("%.0lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值