HDU:Dividing

Dividing

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 66   Accepted Submission(s) : 24
Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.

题意:
数字的位置代表它的价值:
如第一组测试数据:
1 0 1 2 0 0
意思是价值为1的物品有1个,价值为2的物品有0个,价值为3的物品有1个,价值为4的物品有2个,价值为5的物品有0个,价值为6的物品有0个。
若物品有15个,可以转化为1 2 4 8
16个,可以转化为1 2 4 8 1
因为1和2可以组成3,1和4组成5,1和8可以组成9,2和4可以组成6,2和8可以组成10,1 2 4 可以组合成7,则转化后的数可以通过组合,组成1~16间的任何一个数,那么16件物品可以看成分成1个一堆,2个一堆,4个一堆,8个一堆,剩余以个一堆,对应的每堆的价值,等于单个物品的价值乘上物品的件数,然后按照01背包处理即可。
求这种是否平分的问题,首先看总价值是不是偶数,如果是奇数则不能平分。如果是偶数,我们将价值减半作为背包的容量。
先将dp数组刷成负无穷,将dp[0]在赋为0,然后按01背包做,如果最后dp[v]大于0,代表平分了,如果为负责不能平分。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>

using namespace std;

int num[10];
int N,V;
int dp[1000000];
const int inf = 0x3f3f3f3f;
///01背包
void ZeroOnePack(int weight,int value) {
    for(int j = V; j >= weight; j--) {
        dp[j] = max(dp[j],dp[j-weight]+value);
    }
}
///多重背包
void MultiplePack()
{
    for (int i = 1; i <= N; i++)
    {
            int k = 1;
            int nCount = num[i];
            while(k <= nCount)
            {
                ZeroOnePack(k*i,k*i);
                nCount -= k;
                k *= 2;
            }
            ZeroOnePack(nCount*i,nCount*i);
    }
}
int main() {
    int Case = 0;
    while(true) {
        int sum = 0;
        N = 6;
        for(int i = 1; i <= N; i++) {
            scanf("%d",&num[i]);
            sum += (i*num[i]);
        }
        if(sum == 0)
            break;
        printf("Collection #%d:\n",++Case);
        if(sum%2) {
            printf("Can't be divided.\n");
        } else {
            V = sum/2;
            for(int i = 0; i <= V; i++) {
                dp[i] = -inf;
            }
            dp[0] = 0;
            MultiplePack();
            if(dp[V] > 0) {
                printf("Can be divided.\n");
            } else {
                printf("Can't be divided.\n");
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值