北大ACM poj2406 Power Strings

Power Strings
 

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

 

 

/*本题还可以用字符串匹配的经典算法KMP来解决。我觉得KMP很难理解,不过的确是个经典算法。这个问题,只需要用到KMP的构造,也就是对待搜索字符串的自身匹配就可以了

KMP是一种在长字符串中匹配短字符串的无回溯算法,它特别适合待搜索字符串自身有重复的情况,就是像这道题中的abababab之类的串。使用一个辅助数组next[i]记录当下标为i的字符匹配失败时,下一次匹配开始的下标(这里下标从0开始)。如此完成next的构造,并多计算一位,设s的长度为len,则a的长度就是len-next[len],只需再做一个除法就可以完成n的求解了
*/
#include <stdio.h>
#include <string.h>

char s[1000001];
int next[1000001];

int main(void)
{
    int i,j,len,n;
    while(scanf("%s",s),s[0]!='.'){
        len=strlen(s);
        //KMP构造
        i=0,j=-1;
        next[0]=-1;
        while(i<len){
            if(j==-1||s[i]==s[j]){
                i++,j++;
                if(s[i]!=s[j]) next[i]=j;
                else next[i]=next[j];
                printf("next[%d]=%d\n",i,next[i]);
            }
			else j=next[j];
        }
        //判断是否能整除,决定n的值
        //比如abababa,不能整除,n就应该为1,否则就成了错误的答案3
        if(len%(i=len-next[len])==0)
            n=len/i;
        else n=1;
        printf("%d\n",n);
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值