POJ1426 Find The Multiple

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100

111111111111111111

#include <stdio.h>
#include <string.h>
int n,flag=0;
void dfs(int k,long long cut)
{
	int i,j;
	if (flag)	return ;//找到目标便停止搜索。
	if (k==19)	return ;//到第19位的时候便存不下了开始回溯,不然递归结果始终是1000000……
//	printf ("%lld\n",cut);
	if (cut%n==0){
		flag=1;
		printf ("%lld\n",cut);
		return ;
	}
	dfs(k+1,cut*10);//枚举过程
	dfs(k+1,cut*10+1);//将搜索节点作为形参的优点是可以在栈中保存节点数据。
}
int main ()
{
	int i;
	while (scanf ("%d",&n)&&n){
		flag=0;
		dfs(0,1);
	}
	return 0;
}

一开始使用数组进行二进制的枚举,但是需要写一个字符串转换的函数来转换成整形数据,因此在每次递归层的转换操作耗时太大导致超时。

而在AC程序中 如果搜到m则输出,否则搜索m×10和m×10+1直到得出答案同样达到枚举的目的且省略了转换的过程。程序中还有一个技巧便是将搜索节点作为形参达到了在栈中保存数据的目的。虽然将cut作为全局变量也可以通过回溯来达到在栈中保存数据的目的,但是代码将显得更加冗长不具有简洁性。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值