POJ 1141 Brackets Sequence(区间dp + dfs)

题目链接http://poj.org/problem?id=1141


                                                                                           Brackets Sequence

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=220;
const int inf=0x7fffffff;
int pos[maxn][maxn];//从i到j在哪里分开
int dp[maxn][maxn];//从i到j至少添几个符号
char str[maxn];
int len;

void print(int i,int j)
{
  if(i>j)
    return ;//递归出口
  if(i==j)
  {
    if(str[i]=='('||str[i]==')')
      cout<<"()";
    else
      cout<<"[]";
  }
  else if(pos[i][j]==-1)//两边是对称的
  {
    cout<<str[i];
    print(i+1,j-1);
    cout<<str[j];
  }
  else//可分割
  {
    print(i,pos[i][j]);
    print(pos[i][j]+1,j);
  }
}

int main()
{
  cin>>str;
  len=strlen(str);
  memset(dp,0,sizeof(dp));
  for(int i=0;i<len;i++)
    dp[i][i]=1;
  for(int k=1;k<len;k++)//长度
    for(int i=0;i+k<len;i++)//起点
    {
      int j=i+k;
      dp[i][j]=inf;
      if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']'))
      {
        dp[i][j]=dp[i+1][j-1];
        pos[i][j]=-1;//暂时让它等于-1
      }
      for(int mid=i;mid<j;mid++)//这个必须要执行的。
      {
        if(dp[i][j]>(dp[i][mid]+dp[mid+1][j]))
        {
          dp[i][j]=dp[i][mid]+dp[mid+1][j];
          pos[i][j]=mid;
        }
      }
    }
  print(0,len-1);
  cout<<endl;
  return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值