UVA - 11988 Broken Keyboard(用数组实现链表)

You'retyping a long text with a broken keyboard. Well it's not so badly broken. Theonly problem

withthe keyboard is that sometimes the \home" key or the \end" key getsautomatically pressed

(internally).

You'renot aware of this issue, since you're focusing on the text and did not eventurn on the

monitor!After you nished typing, you can see a text on the screen (if you turn on themonitor).

InChinese, we can call it Beiju. Your task is to nd the Beiju text.

 

Input

Thereare several test cases. Each test case is a single line containing at least oneand at most 100,000

letters,underscores and two special characters `[' and`]'. `['means the \Home" key is pressed

internally,and `]'means the \End" key is pressed internally. The input is terminated byend-of- file(EOF).

 

Output

Foreach case, print the Beiju text on the screen.

 

SampleInput

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

 

SampleOutput

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University


#include <cstdio>
#include <string.h>
using namespace std;
const int MAX = 100005;
int last, cur, next[MAX];
char s[MAX];
int main()
{
    while(scanf("%s", s+1) == 1){
        int n = strlen(s+1);
        last = cur = 0;
        next[0] = 0;
        for(int i = 1; i <= n; i++){
            char ch = s[i];
            if(ch == '[')  cur = 0;
            else if(ch == ']')  cur = last;
            else{
                next[i] = next[cur];
                next[cur] = i;
                if(cur == last) last = i;
                cur = i;
            }
        }
        for(int i = next[0]; i != 0; i = next[i])
            printf("%c", s[i]);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值