解决TensorFlow安装问题: Could not find a version that satisfies the requirement tensorflow

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/xavier_muse/article/details/83998744

环境:win7 64  

Python版本:3.7.0

安装过程中提示:Could not find a version that satisfies the requirement tensorflow,很是郁闷啊,最后度娘了一下知道了就是因为Python版本的问题啊TensorFlow版本目前还不支持Python3.7版本。前几天刚升级的3.7啊,哭晕在厕所~~~

解决办法:

1、卸载,重新使用anaconda安装对应3.6版本的Python。

2、将3.7版本的Python降级为3.6

本文使用的是第2种方法,降级。

打开anaconda prompt:输入如下代码:

conda install python=3.6

等待提示(y/n?)输入:y

等待降级过程,大约15分钟左右,会提示done

命令行输入:python

提示Python版本降级为3.6.2了,下面进行TensorFlow的安装。

(1)在anaconda prompt利用anaconda创建一个名为tensorflow的Python3.6环境

conda create -n tensorflow python=3.6

(2)启动tensorflow环境:

activate tensorflow

当不使用tensorflow时,关闭tensorflow环境,命令为:deactivate

(3)安装tensorflow:

cpu版本:pip install --ignore-installed --upgrade tensorflow

gpu版本:pip install --ignore-installed --upgrade tensorflow-gpu 注意gpu版先装好cuda以及cudnn 
等待安装完成。

我安装的CPU版:

等待安装完成。。。。。。。

(4)测试TensorFlow,切换到Python下:

 

如此,则安装TensorFlow成功了。

TensorFlow安装参考了朋友博客:https://blog.csdn.net/lwplwf/article/details/54896088

展开阅读全文

没有更多推荐了,返回首页