POJ3273——Monthly Expense

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500


题目理解:

给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值,二分法

#include<iostream>
using namespace std;

#define MAXVAL -1000000

int moneys[100000];

//calculate the groups when the limit is money
int is_divide(int money, int length)
{
	int cnt = 1;      //just one group
	int sum = 0;
	for (int i = 0; i < length; ++i)
	{
		sum += moneys[i];
		if (sum>money)
		{
			cnt++;
			sum = moneys[i];    //next group start
		}
	}
	return cnt;
}

int main()
{
	int length;
	int k;
	scanf("%d%d", &length, &k);
	//cin >> length >> k;             //the runtime is faster
	int right = 0;
	int left = MAXVAL;
	for (size_t i = 0; i < length; i++)
	{
		//cin >> moneys[i];
		scanf("%d", &moneys[i]);
		right += moneys[i];                           //divide into one group
		left = moneys[i]>left ? moneys[i] : left;      //divide into length groups
	}
	int mid = left;
	while (left <= right)
	{
		mid = (left + right) >> 1;
		int cnt = is_divide(mid, length);
		if (cnt > k)                        //groups is less,so should be enlarge the left    
		{
			left = mid + 1;
		}
		//pay attention:although maybe the cnt==k,the right is also large,and on the contrary,if
		//the cnt>k,the max is small of course
		else        //groups is big,so should be ensmaller the right
		{
			right = mid - 1;
		}
	}
	//cout << mid << endl;
	printf("%d\n", mid);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值