1061. Dating (20)【字符串操作】——PAT (Advanced Level) Practise

题目信息

1061. Dating (20)

时间限制50 ms
内存限制65536 kB
代码长度限制16000 B
Sherlock Holmes received a note with some strange strings: “Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm”. It took him only a minute to figure out that those strange strings are actually referring to the coded time “Thursday 14:04” – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter ‘D’, representing the 4th day in a week; the second common character is the 5th capital letter ‘E’, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is ‘s’ at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format “DAY HH:MM”, where “DAY” is a 3-character abbreviation for the days in a week – that is, “MON” for Monday, “TUE” for Tuesday, “WED” for Wednesday, “THU” for Thursday, “FRI” for Friday, “SAT” for Saturday, and “SUN” for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04

解题思路

找出相同字符,要注意每个字符的范围,比如代表星期的字母在A-G之间

AC代码

#include <cstdio>
#include <cstring>
#include <cctype>
char s[4][65];
char name[7][4] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
int main()
{
    scanf("%s%s%s%s", s[0], s[1], s[2], s[3]);
    int week = -1, hour, minute;
    for (int i = 0; s[0][i] && s[1][i]; ++i){
        if (s[0][i] == s[1][i]){
            if (week == -1 && s[0][i] >= 'A' && s[0][i] <= 'G'){
                week = s[0][i] - 'A';
            }else if (week != -1 && (isdigit(s[0][i]) || (s[0][i] >= 'A' && s[0][i] <= 'N'))) {
                if (isdigit(s[0][i])){
                    hour = s[0][i] - '0';
                }else {
                    hour = s[0][i] - 'A' + 10;
                }
                break;
            }
        }
    }
    for (int i = 0; s[2][i] && s[3][i]; ++i){
        if (s[2][i] == s[3][i] && isalpha(s[2][i])){
            minute = i;
            break;
        }
    }
    printf("%s %02d:%02d\n", name[week], hour, minute);
    return 0;
}

个人游戏推广:
《10云方》与方块来次消除大战!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值