PAT A1062

  • 题目:
    About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.
Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10​5​​), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.
Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.
Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

  • 解题思路
    将人按照题意分为5类,在分别按照类别,总分,德分,序号排序
    注意事项:
    由于数据量较大,需要用scanf来进行输入,printf进行输出,不然会运行超时
#include <iostream>
#include<algorithm>
#include<string>
#include<cstdio>
using namespace std;
struct student{
    string id;
    int vir, tal, sum;          //德,才,总分
    int tag;                    //类别
}stu[100010];
bool cmp(student a, student b)
{
    if(a.tag != b.tag) return a.tag < b.tag;                 //按类别排序,从小到大排序
    else if(a.sum != b.sum)  return a.sum > b.sum;            //类别相同,按照总分排序,从大到小排序
    else if(a.vir != b.vir)  return a.vir > b.vir;            //总分相同,按照德分排序
    else
        return a.id < b.id;                                 //否则按照准考证号排序
}
int main()
{
    int num, low, high;                    //总人数,最低分,最高分
    int k = 0;                       //合格的总人数
    cin >>num >> low >> high;
    for(int i =0; i < num; i++){
        string temp ;
        int de, cai;
        cin >>temp;
        scanf("%d %d",&de,&cai);
        if(de <low || cai < low){
            continue;
        }
        else if(de >= high && cai>= high){
            stu[k].vir = de;
            stu[k].tal = cai;
            stu[k].id = temp;
            stu[k].sum = de+cai;
            stu[k].tag = 1;
            k++;
        }
        else if(de >= high && cai<high){
            stu[k].vir = de;
            stu[k].tal = cai;
            stu[k].sum = de+cai;
            stu[k].id = temp;
            stu[k].tag = 2;
            k++;
        }
        else if(de <high && cai < high && de >=cai){
            stu[k].vir = de;
            stu[k].tal = cai;
            stu[k].sum = de+cai;
            stu[k].id = temp;
            stu[k].tag = 3;
            k++;
        }
        else {
            stu[k].vir = de;
            stu[k].tal = cai;
            stu[k].id = temp;
            stu[k].sum = de+cai;
            stu[k].tag = 4;
            k++;
        }
    }
    sort(stu, stu+k, cmp);
    cout << k << endl;
    for(int i=0; i < k; i++){
        cout << stu[i].id;
        printf(" %d %d\n",stu[i].vir, stu[i].tal);

    }
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值