PAT A1050

  • 题目:
    Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.
    Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:

For each test case, print S​1​​−S​2​​ in one line.
Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意:给出两个字符串,在第一个字符串中删除第二个字符串中所有出现的字符。

分析:用Hash[128]标记所有可能出现的字符,若在st1中出现,则Hash相应位置置为1,若在st2中出现,则将相应位置置为0,最后对于st1中的每个字符,若在Hash中的值为1,则输出此字符

注意:字符输出为:printf("%c",x);
string 读取整行用: getline(cin, st1);

#include <cstdio>
#include <iostream>
#include <string>
using namespace std;
int Hash[128] = {0};
int main()
{
    string st1, st2;
    getline(cin, st1);
    getline(cin, st2);
    int len1 = st1.size(), len2 = st2.size();
    for(int i = 0; i < len1; i++){
        Hash[st1[i]] =1;
    }
    for(int i = 0; i < len2; i++){
        Hash[st2[i]] = 0;
    }
    for(int i = 0; i < len1; i++){
        if(Hash[st1[i]] == 1)
            printf("%c", st1[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值