PAT A1048

5 篇文章 0 订阅
4 篇文章 0 订阅
  • 题目:
    Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
    Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.
Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

  • 题目大意
    给出n个正整数和一个正整数m,问n个数字中是否存在一对数字a和b(a<=b)使得a+b成立。如果有多对,输出a最小的那一对

  • 分析

  • 方法一:hash散列
    1.value数组里面存放诶个数字出现的次数
    2.枚举1~1000里面的每个数字,若value[i]和value[m-i]都不为0,则输出则两个数。当m-i == i时,value[i] 里面的数字必须大于等于2

代码实现:

#include <cstdio>
int value[1001] = {0};
int main()
{
    int n, m, temp;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++){
        scanf("%d", &temp);
        value[temp]++;;
    }
    if(m % 2 == 0){                    //单独判断m-i == i时
        if(value[m/2] >= 2){
            printf("%d %d", m/2, m/2);
            return 0;
        }
    }
    for(int i = 1; i <= m/2; i++){
        if(value[i] != 0  && value[m-i] != 0 && i != m-i){
            printf("%d %d", i, m-i);
            return 0;
        }
    }
    printf("No Solution");
    return 0;
}

  • 方法二:二分法
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
bool tag = false;
int bin_search(int A[], int i, int j , int  M){
    int l = i, r = j, mid;
    while(l < r){
        mid = (l+r)/2;
        if(A[mid] >= M)
            r = mid;
        else
            l = mid+1;
    }
    if(A[l] == M){
        tag = true;
    }
    return l;
}
int main()
{
    int n, M, A[100010];
    scanf("%d%d", &n, &M);
    for(int i = 0; i < n; i++)
        scanf("%d", &A[i]);
    sort(A, A+n);
    for(int i = 0; i < n-1; i++){                             //注意不是小于n,不然xiamiani+1会超出边界
        int j = bin_search(A, i+1, n-1, M-A[i]);         //从i+1个数开始找
        if(tag == true){
            printf("%d %d", A[i], A[j]);
            return 0;
        }
    }
    if(tag == false)
    printf("No Solution");
    return 0;
}

利用STL lower_bound()函数实现:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int main()
{
    int n, M, A[100010];
    scanf("%d%d", &n, &M);
    for(int i = 0; i < n; i++)
        scanf("%d", &A[i]);
    sort(A, A+n);
    for(int i = 0; i < n-1; i++){
        int j = lower_bound(A+i+1, A+n-1, M-A[i])-A;
        if(A[i]+ A[j] == M){
            printf("%d %d", A[i], A[j]);
            return 0;
        }
    }
    printf("No Solution");
    return 0;
}

  • 方法三:two pointers
    若A[i] + A[j] < value, i++ (数组非减)
    若A[i] + A[j] > value, j–
    若A[i] + A[j] == value , 输出i,j
#include <cstdio>
#include <algorithm>
const int Max = 100010;
using namespace std;
int main()
{
    int num, value, A[Max];
    scanf("%d%d", &num, &value);
    for(int i = 0; i < num; i++){             //输入数组A
        scanf("%d", &A[i]);
    }
    sort(A, A+num);                  //对数组A从小到大排序
    int i = 0, j = num-1;
    while(i < j){
        if(A[i] + A[j] == value){
            printf("%d %d", A[i], A[j]);
            return 0;
        }
        else if(A[i] + A[j] < value)
            i++;
        else
            j--;
    }
    printf("No Solution");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值