PAT A1059

  • 题目:
    Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.
    Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.
Output Specification:

Factor N in the format N = p​1​​k​1​​*p​2​​k​2​​*…*p​m​​^k​m​​, where p​i​​’s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ – hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.
Sample Input:

97532468

Sample Output:

97532468=2^211171011291

  • 代码实现:
#include <vector>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX = 100010;
vector<long long  > pri;
vector<bool> tag(MAX, false);
void find_pri(){                                                //素数表的建立
    for(int i = 2; i < MAX; i++){
        if(tag[i] == false){
            pri.push_back(i);
            for(int j = i + i; j < MAX; j += i)
                tag[j] = true;
        }
    }
}
struct node{
    long long pri_num;
    int num = 0;
};
int main()
{
    vector<node> res(10);
    int n ,index = 0;
    cin >> n;
    if( n == 1){
        cout <<"1=" <<1;
        return 0;
    }
    cout << n << "=";
    find_pri();
    int size1 = (int) sqrt(1.0 * n);
    int size2 = pri.size();
    for(int i = 0; i < size1 && i < size2 ; i++){
        if(n % pri[i] == 0){
            res[index].pri_num = pri[i];
            while(n % pri[i] == 0){
                res[index].num++;
                n /= pri[i];
            }
            index++;
        }
        if( n == 1)
            break;
    }
    if(n != 1){                                          //当n本身为素数时
        res[index].pri_num = n;
        res[index].num++;
        index++;
    }
    for(int i = 0; i < index-1; i++){                 //输出
        if(res[i].num != 1){
            cout << res[i].pri_num << "^" << res[i].num << "*";
        } else{
            cout << res[i].pri_num << "*";
        }
    }
    if(res[index-1].num == 1){
        cout << res[index-1].pri_num;
    } else {
        cout << res[index-1].pri_num << "^" << res[index-1].num;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值