PAT (Advanced Level) Practice 1003 Emergency (25分) java实现

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1
​​ and C
​2
​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C
​1
​​ to C
​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C
​1
​​ and C
​2
​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:
2 4


import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
	
  /* 找dist值最小的结点 */
	public static int findMin(int[] dist, boolean[] collected, int infinity) {
		int minV, minLength;
		minV = -1;
		minLength = infinity;
		
		for (int i=0; i<dist.length; i++) {
			if (!collected[i] && dist[i] < minLength) {
				minLength = dist[i];
				minV = i;
			}
		}
		return minV;
	}
	
  /* dijstra算法 */
	public static void dijkstra(int[][] graph, int s, int[] dist, 
			int[] num, int[] w, int[] weight, boolean[] collected, int infinity) {
		for (int i=0; i<graph.length; i++) {
			if (graph[s][i] < infinity) {
				dist[i] = graph[s][i];
				num[i] = 1;
				w[i] = weight[s] + weight[i];
			}
		}
		
		dist[s] = 0;
		w[s] = weight[s];
		num[s] = 1;
		collected[s] = true;
		
		int u, v;
		while(true) {
			u = findMin(dist, collected, infinity);
			if (u == -1) break;
			collected[u] = true;
			for (v=0; v<graph.length; v++) {
				if (graph[u][v] < infinity && !collected[v]) {
					if (dist[u] + graph[u][v] < dist[v]) {
						dist[v] = dist[u] + graph[u][v];
						num[v] = num[u];
						w[v] = weight[v] + w[u];
					} else if (dist[u] + graph[u][v] == dist[v]){
						num[v] += num[u];
						if (w[v] < w[u] + weight[v]) {
							w[v] = w[u] + weight[v];
						}
					}
				}
			}
		}
		
	}

	public static void main(String[] args) throws IOException{
		BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
		String[] line1 = reader.readLine().split(" ");
		String[] weights = reader.readLine().split(" ");

		int n, m, c1, c2;
		n = Integer.valueOf(line1[0]);
		m = Integer.valueOf(line1[1]);
		c1 = Integer.valueOf(line1[2]);
		c2 = Integer.valueOf(line1[3]);
		
		// 点权重列表
		int[] weight = new int[n];
		for (int i=0; i<n; i++) {
			weight[i] = Integer.valueOf(weights[i]);
		}
		// 建图
		int[][] graph = new int[n][n];
		int infinity = 99999;
		for (int i=0; i<n; i++) {
			for (int j=0; j<n; j++) {
				graph[i][j] = infinity;
			}
		}
		// 连边
		for (int i=0; i<m; i++) {
			String[] road = reader.readLine().split(" ");
			int v1 = Integer.valueOf(road[0]);
			int v2 = Integer.valueOf(road[1]);
			int l = Integer.valueOf(road[2]);
			graph[v1][v2] = l;
			graph[v2][v1] = l;
		}
		
		reader.close();
		
		// 一些记录数组
		int[] w = new int[n];  // 记录从开始到目前的救援队总数
		int[] num = new int[n];  // 记录某点的最短路径条数
		int[] dist = new int[n];  // 各点到原点的距离
		boolean[] collected = new boolean[n];  // 记录某点是否被访问过--初始false 
		
		for (int i=0; i<n; i++) {
			dist[i] = infinity;
		}
		
		dijkstra(graph, c1, dist, num, w, weight, collected, infinity);
		System.out.println(num[c2] + " " + w[c2]);

	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值