poj 1797 Heavy Transportation

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 16299 Accepted: 4263

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

 

题意:n个点,m个路径,从1点出发到n点的最短路径里的最大一条路径,prim树复习时候做的第一道练手题,总的来说和地杰斯特拉差不多的思路~

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=99999999;
int map[1005][1005];
bool vis[1005];
int dist[1005];
int prim(int n,int v)
{

    int u;
    int mmin=maxn;
    int mintemp=maxn;
    for (int i=1 ; i<=n ; i++)
        map[i][i] = maxn;
    for (int i=1;i<=n;i++)
    {
        dist[i]=map[v][i];
        vis[i]=0;
    }
    dist[v]=0;
    vis[v]=1;

    for (int i=1;i<=n;i++)
    {
        int temp=-1;   //因为要找最大值 所以temp赋值为-1;
        int u=v;
        for (int j=1;j<=n;j++)
        {
            if (!vis[j]&&(dist[j]>temp)) //找到最短的点 并把最短的点放到已经标记的集合里

            {
                u=j;
                temp=dist[j];
            }
        }

        vis[u]=1;
        for (int j=1;j<=n;j++)
        {

            if (dist[u]<map[u][j])   //这一步也可以用min(map[u][j],dist[u]);
                mintemp=dist[u];
            else
                mintemp=map[u][j];
            if (!vis[j]&&dist[j]<mintemp)
            {
                dist[j]=mintemp;
            }
        }
    }
    return dist[n];
}

int main()
{
    int cas;
    cin>>cas;
    int n,m;
    int u,v,weight;
    int t=0;
    while (cas--)
    {
        cin>>n>>m;
        for (int i=1;i<=n;i++)
            for (int j=1;j<=n;j++)
            {


                map[i][j]=0;
                vis[i]=0;
            }

        for (int j=1;j<=m;j++)
        {
            cin>>u>>v>>weight;
            map[u][v]=map[v][u]=weight;
        }
        cout<<"Scenario #"<<++t<<":"<<endl;
        cout<<prim(n,1)<<endl;
       
       if (cas) cout<<endl ;


    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值