poj 2524 Ubiquitous Religions

                                                                                                                               Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 18313 Accepted: 8970

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7
题意:

世界上有很多宗教,很难掌握所有人信仰了什么宗教。现在要统计学校有多少个宗教信仰。他知道学校有n(0 < n <= 50000)个学生,他去问每一个学生信仰什么教是不可能的。而且,许多同学也不想告诉他,一种方法解决这些问题,要求m(0 <= m <= n(n-1)/2)对同学,并询问他们是否信仰同一种宗教(例如,他们可能互相知道,如果他们都出席同一宗教会议)。从这些数据,你可能不知道每个人是否参加,但你可以得到的,究竟可能最多有多少宗教信仰。显然每个人只能信仰一种宗教。要得出的就是最后的宗教信仰数。

做的第一道并查集题 ,后来用了数组和结构体解的题~

代码:
 
数组:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int parent[50005];
int rank[50005];
int flag[50005];
void make_set(int i)
{
	parent[i]=i;
	rank[i]=0;	
}

int get_parent1(int x)
{
	if(parent[x]!=x)
	parent[x]=get_parent1(parent[x]);
	
	return parent[x];
	
}
void Union(int a,int b)
{
	a=get_parent1(a);
	b=get_parent1(b);
	if(a==b) return ;
	if(rank[a]>rank[b])
	 parent[b]=a;
	 else
	 {
 		if(rank[a]==rank[b])
 		rank[b]++;
 		parent[a]=b;
 	}
}
int main()
{
	int n,m;
	int a,b;
	
	int sum;
	int t=0;
	while(cin>>n>>m&&(n||m))
	{
		memset(flag,0,sizeof(flag));
		for(int i=1;i<=n;i++)
		 make_set(i);
		 
		 for(int i=1;i<=m;i++)
		 {
 			cin>>a>>b;
 			Union(a,b);
 		}
 		sum=0;
 		for(int i=1;i<=n;i++)
 		{
		 	int c=get_parent1(i);
		 	if(!flag[c])
		 	{
	 			sum++;
	 			flag[c]=1;
	 		}
		 }
 		cout<<"Case "<<++t<<": "<<sum<<endl;
		
	}
	return 0;
}
 
 
结构体:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int parent[50005];
int rank[50005];
int flag[50005];
struct Node{
	int parent;
	int rank;
	
}node[50005];
void make_set(int i)
{
	node[i].parent=i;
	node[i].rank=0;	
}

int get_parent1(int x)
{
	if(node[x].parent!=x)
	node[x].parent=get_parent1(node[x].parent);
	
	return node[x].parent;
	
}
void Union(int a,int b)
{
	a=get_parent1(a);
	b=get_parent1(b);
	if(a==b) return ;
	if(node[a].rank>node[b].rank)
	 node[b].parent=a;
	 else
	 {
 		if(node[a].rank==node[b].rank)
 		node[b].rank++;
 		node[a].parent=b;
 	}
}
int main()
{
	int n,m;
	int a,b;
	
	int sum;
	int t=0;
	while(cin>>n>>m&&(n||m))
	{
		memset(flag,0,sizeof(flag));
		for(int i=1;i<=n;i++)
		 make_set(i);
		 
		 for(int i=1;i<=m;i++)
		 {
 			cin>>a>>b;
 			Union(a,b);
 		}
 		sum=0;
 		for(int i=1;i<=n;i++)
 		{
		 	int c=get_parent1(i);
		 	if(!flag[c])
		 	{
	 			sum++;
	 			flag[c]=1;
	 		}
		 }
 		cout<<"Case "<<++t<<": "<<sum<<endl;
		
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值