poj 1502 MPI Maelstrom 单源最短路+dijkstra算法

题目:

MPI Maelstrom
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8659 Accepted: 5335

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35




N个处理器要进行信息传递,处理器之间有着双向边,i到j与j到i传递信息的时间是相同的,传信息给自己不需要时间,不同处理器之间传递信息所需时间由下三角矩阵给出。若矩阵对应位置为x,说明相应的两个处理器之间没有边,无法传信息。求从第一个处理器传信息到其他所有处理器所需的最少时间。


分析:
意即求单源最短路中的最大值。

若用邻接矩阵,难点在于建图。

建图可参考:

http://blog.csdn.net/yuer158462008/article/details/21408339

其中用到了sscanf函数,入门请参考:

http://blog.csdn.net/sjf0115/article/details/8579935


代码:

#include <stdio.h>
#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
#include <math.H>
#include <limits.h>
using namespace std;
const int maxn=109;
const int inf=(INT_MAX)/3;
typedef pair<int,int> p;

struct edge{
	int to;
	int cost;
};

int n,d[maxn];

vector<edge> g[maxn];

void dijkstra(int s){
	priority_queue<p,vector<p>,greater<p> >qu;//堆按照p的first(最短距离)排序,小在前 
	fill(d,d+maxn,inf);
	d[s]=0;
	qu.push(p(0,s));//从起点出发到顶点s的最短距离为0
	while(!qu.empty()){
		p temp=qu.top();
		qu.pop();
		if(temp.first>d[temp.second]) continue;//跳过更新过程中入队的非最小值 
		for(int i=0;i<g[temp.second].size();++i){//遍历该顶点连出的每条边 
			edge e=g[temp.second][i];
			if(d[e.to]>d[temp.second]+e.cost){
				d[e.to]=d[temp.second]+e.cost;
				qu.push(p(d[e.to],e.to));
			}
		}
	}
}

int main(){
	int a,t,maxn;
	edge e;
	char s[5];
	while(~scanf("%d",&n)){
		for(int i=2;i<=n;++i){
			for(int j=1;j<i;++j){
				scanf("%s",s);
				if(s[0]=='x') continue;
				sscanf(s,"%d",&t);//从s中读入整数赋给t
				e.to=i;
				e.cost=t;
				g[j].push_back(e);
				e.to=j;
				g[i].push_back(e);
			}
		}
		dijkstra(1);
		maxn=0; 
		for(int i=1;i<=n;++i){
			maxn=max(maxn,d[i]);
		}
		printf("%d\n",maxn);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值