hdu5734 Acperience(数学)

Acperience

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 516    Accepted Submission(s): 278


Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn) . Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi{+1,1}) and a scaling factor α0 in such a manner that WαB2 is minimum.

Note that denotes the Euclidean norm (i.e. X=x21++x2n , where X=(x1,x2,...,xn) ).
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first line contains an integers n (1n100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (10000wi10000) .
 

Output
For each test case, output the minimum value of WαB2 as an irreducible fraction " p / q " where p , q are integers, q>0 .
 

Sample Input
  
  
3 4 1 2 3 4 4 2 2 2 2 5 5 6 2 3 4
 

Sample Output
  
  
5/1 0/1 10/1
 

Author
zimpha
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5746  5745  5743  5741  5740 



我的:
  这个题目最重要的就是: ,然后这个式子看成二元一次方程组,再注意一点细节就好了。


#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<set>
#include<vector>
#include<map>


using namespace std;

const int maxn=100000+10;


typedef long long ll;


//int gcd(int x,int y)
//{
//    if(y==0)
//        return x;
//    return gcd(y,x%y);
//}

ll gcd(ll x,ll y)
{
    if(y==0)
        return x;
    return gcd(y,x%y);
}

ll work(ll x)
{
    if(x<0)
        return -x;
    return x;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        ll w[maxn];
        ll  absolute_value=0,quare_sum=0;
        for(int i=0;i<n;i++)
            cin>>w[i],absolute_value+=work(w[i]),quare_sum+=w[i]*w[i];
        ll a=absolute_value*absolute_value;
        ll temp=gcd(a,n);
        a=a/temp;
        n=n/temp;
        a=quare_sum*n-a;
        temp=gcd(n,a);
        a=a/temp;
        n=n/temp;
        cout<<a<<"/"<<n<<endl;
    }
}

美素数hdu4548

水题,直贴代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1000000 + 10;
bool is_prime[maxn];
int prime[maxn];
bool vis[maxn];
int a[maxn];
void Init()
{
    memset(is_prime,true,sizeof(is_prime));
    is_prime[0] = is_prime[1] = false;
    for(int i = 2; i <maxn ; ++ i)
    {
        if(is_prime[i])
            for(int j = i * 2; j < maxn ; j += i)
        {
            is_prime[j] = false;
        }
    }
    memset(vis,false,sizeof(vis));
    for(int i = 1; i < maxn ; ++ i)
    {
        if(is_prime[i])
        {
            int sum = 0;
            int t = i;
            while(t)
            {
                sum += t % 10;
                t /= 10;
            }
            if(is_prime[sum])
            {
                vis[i] = true;
            }
        }
    }
    a[0] = 0;
    for(int i = 1; i < maxn ; ++ i)
    {
        if(vis[i])
        {
            a[i] = a[i - 1] + 1;
        }
        else a[i] = a[i - 1];
    }

}
int main()
{
    Init();
    int Tcase;
    scanf("%d",&Tcase);
    for(int ii = 1; ii <= Tcase ; ++ ii)
    {
//        for(int i = 1; i < 100 ; ++ i)
//        cout << a[i] << " ";
//        cout << endl;
        int x,y;
        scanf("%d%d",&x,&y);
//        cout << a[y]<< " "<<a[x - 1] << endl;
        printf("Case #%d: %d\n",ii,a[y] - a[x - 1]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值